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Это не коммерческое программное средство разработано для научно-исследовательской 
цели  в  Laboratorium     f  ü  r     Informationstechnologie  ,  Университет  Ганновера.  Свободная 
лицензия  дает  право  любой  личности  или  учреждению  использовать,  копировать  и 
распространять этот продукт, при условии, что это это уведомление о лицензии и пакет 
документации  будут  присутствовать  во  всех  копиях  в  неизменном  виде.  Университет 
Ганновера поставляет этот продукт «как есть», без явной или неявной гарантии. 

Обзор
Voodoo Camera Tracker производит  получение  информации  о  параметрах  реальной 
камеры из последовательности кадров (image sequences), для дальнейшего повторения ее 
поведения в 3D сцене.   Такой процесс  называется  трекингом.  Используемый алгоритм 
трекинга  позволяет  произвести  его  в  автоматическом  режиме  с  высокой  степенью 
достоверности. Результаты трекинга могут быть использованы для производства фильмов, 
3D реконструкции  реальных  сцен  или  видеокодирования.  Полученные  в  результате 
трекинга параметры могут быть экспортированы в различные пакеты 3D анимации:  3  D   
Studio     Max  , Blender, Lightwave, Maya, или Softimage. 

Voodoo Camera Tracker работает на уровне коммерческих программ для трекинга камеры, 
(так же называемого  match movers), таких, как  3  D  -  Equalizer     by     Science  -  D  -  Visions  ,  boujou 
by   2  d  3  ,  Matchmover     by     RealViz     ,  PFTrack   от    The     Pixel     Farm  ,  SynthEyes   от    Andersson   
Technologies. Пожалуйста, выберите коммерческий продукт, если вам необходим трекер с 
профессиональной поддержкой. 

Процесс трекинга состоит из пяти шагов: 

 Автоматическое обнаружение характерных пикселей   
 Автоматический анализ полученой информации   
 Устранение ошибок   
 Интелектуальная оценка параметров камеры  

 Окончательное уточнение параметров камеры   

Автоматическое определение характерных пикселей

Характерные  пиксели  определяются  с  суб-пиксельной  точностью  детектором  угла. 
Обнаруженные характерные пиксели в текущем кадре выделяются зелеными крестиками. 
Характерные  пиксели,  которые  опознаются  как  ошибочные  во  время  обработки, 
выделяются красными крестиками. 
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Рис.1 Определение характерных пикселей.

Автоматический анализ полученной информации

Осуществляется  прослеживание одного кадра к другому для  пикселей,  которые имеют 
наибольшую контрастность между самим пикселем и окружающей областью. Смещение 
прослеженных пикселей относительно предыдущего  кадра  отображается  желтыми 
линиями. 

Рис.2 Прослеживание характерных пикселей.

Устранение ошибок

Из-за сбоев в обнаружении пикселей, или присутствия на изображении самостоятельно 
движущихся объектов,  часть информации может оказаться  неверной.  Для того,  что бы 
достигнуть точного соответствия, применен алгоритм случайной выборки, позволяющий 
обнаружить ошибочные пиксели, называемые «выпадающими» - outliers. 

Интелектуальная оценка параметров камеры



Параметры  камеры  вычисляются  с  помощи  метода  последовательных  приближений  и 
техники  оптимизации  по  данным  «доброкачественных  пикселей»,  называемых 
«попадающими» - inliers.

Окончательная оценка параметров камеры

Последний  шаг  —  уточнение,  применяется  после  вычисления  всех  параметров 
последовательности  изображений.  Этот  шаг  представляет  собой  попытку  «размазать» 
ошибку погрешности расчетов равномерно по всей последовательности кадров, сглаживая 
ошибки  движения  камеры.  Теперь  виртуальные  объекты  могут  быть  интегрированы  в 
реальную видеопоследовательность. 

Рис.3 Собственно видеопоследовательность.

Download
Voodoo Camera Tracker можно  свободно  загрузить  с  адреса  http  ://  www  .  digilab  .  uni  -  
hannover  .  de   как библиотеку для Linux и Windows. 

Использование
Типичный трекинг камеры включает в себя несколько шагов: 

 Загрузка секвенции из кадров видео ( Load an Image Sequence ) 
 Установка начальных параметров камеры вручную или через загрузку файла 

камеры. 
 Настройка некоторых элементов управления процессом трекинга. 
 Старт трекинга, нажатием кнопки Track в правом нижнем углу. 
 Проверка  Параметров камеры при помощи Инструментов моделирования на 

имеющихся тестовых 3D объектах, или просмотром 3D сцен в  3  D     Scene     Viewer  . 
 Добавление параметров камеры запуском дополнительной коррекции или 

редактирование дорожек пикселей вручную с использованием Инструментов 
моделирования или  Редактором трека   FPoint  . 

 Экспорт полученных параметров камеры в пакет 3D анимации 3  D     Studio     Max  , 
Blender, Lightwave, Maya, или Softimage. 
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Главное окно трекинга

После того, как вы запустите voodoo откроется окно трекинга (Main Tracking) (Рис. 4).

Рис 4. Окно Main Tracking

Верхняя панель меню этого окна имеет следующую структуру: 

 File ( работа с  файлом) 
o Load (загрузка)

 Sequence   ( последовательность кадров) 
 Initial Camera   ( начальные установки камеры)
 CAHV Cameras   (установки камер типа CAHV)
 Feature Points    ( характерные пиксели)
 User Primitives   ( пользовательские примитивы)

o Save  ( сохранение)
 3D MAX Script   ( скрипт для камеры в формате 3D MAX) 
 Blender Python Script   (скрипт для камеры в формате Блендер)
 Lightwave 3D   (скрипт для камеры в формате Lightwave 3D)
 Maya Script   (скрипт для камеры в формате Maya)
 Softimage 3.9 | XSI   (скрипт для камеры в формате Softimage)
 Textfile   (текстовый файл с параметрами камеры)
 CAHV Cameras   (CAHV камеры)
 Feature Points   ( характерные пиксели)
 User Primitives   ( пользовательские примитивы)

o Exit (выход)
 View ( вызов рабочих окон программы)

o Controls   ( элементы управления)
o Draw Options   ( опции рисования)
o Camera Parameter   ( параметры камеры)
o 3D Scene Viewer   ( 3D просмотрщик)
o Modelling Tools    ( инструменты моделирования)
o FPoint Track Editor   ( редактор трека FPoint)

 Help  ( помощь )
o Help   ( помощь)
o Notify Level   ( о программе)

File → Load → Sequence
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Если выбрать этот пункт из меню, открывается окно выбора видеопоследовательности - 
(Рис. 5).

Рис 5. Окно выбора видеопоследовательности.

Вы  можете  загрузить  видеопоследовательность,  представленную  только  отдельными 
кадрами (  медиа  контейнеры  AVI,  MOV  и.т.п.  не  поддерживаются)  и  в  единственном 
формате   -  Targa 2.0  (  формат  с  расширением  .tga)  ( более  ранние  версии  для  Linux 
позволяли выбрать ряд других форматов, но в последней версии эта поддержка отменена, 
по  видимому  из-  за  не  стабильной  работы  с  другими  форматами  (  примечание 
переводчика)).

 Щелкните LBM на Browse, откроется окно загрузки файлов. 
 Выберите имя файла последовательности, с которой собираетесь работать.

Например, если вы хотите открыть видеопоследовательность: 
"./sample_image_sequence/uni.##.tga" ( здесь значек ## означает номер кадра), вы 
сначала выбираете каталог с названием "sample_image_sequence", затем щелкаете 
на первом файле из видеопоследовательности, например"uni.00.tga". После чего 
щелкаете на Open.
Voodoo Camera Tracker самостоятельно обнаружит все остальные файлы 
последовательности, начиная с выбранного. При этом после загрузки очередного 
кадра автоматически увеличивается на значение шага (Step) счетчика кадров ( по 
умолчанию — на 1) и полученное значение используется для поиска нового файла - 
кадра с этим номером в исходной директории. Voodoo Camera Tracker может 
начинать нумерацию и не с нулевого кадра. Если у вас нумерация ведется не с 
нуля, пожалуйста, выберете файл с самым большим номером в окне просмотра. 

 Voodoo Camera Tracker записывает обнаруженные стартовый и конечный номера 
файлов видеопоследовательности (Start, End) и шаг счетчика чередования 
последовательности (Step)  в текстовой области. Вы можете изменять по своему 
желанию эти значения. Например, изменив значение step на 2, мы заставим трекер 
пропускать каждый четный кадр. 

 В поле Deinterlace вы можете выбрать дну из трех опций. Первая - not interlaced  - 
выбирается, если ваши изображения оцифрованы с кинопленки или видеокамеры, 
использующей прогрессивную развертку. Все бытовые видеокамеры снимают в 
полукдровой ( черезстрочной) развертке и, если ваша видеопоследовательность не 
проходила предварительно процесс деинтерлессинга специальными программами, 
данный режим не для вас. В этом случае необходимо определиться с 
последовательностью чередования строк на вашей камере. Как правило, если 
камера снимает в формате DV , то первым идет четное поле и необходимо выбрать 
пункт с значением «нижнее поле первое» (maintain odd lines ) , а если вы 
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обрабатываете видеопоследовательность с аналоговых камер форматов BetaCAM, 
VHS, SVHS, Video8 и SVideo8, то первым будет идти нечетное поле и нужно 
выбрать maintain even lines. 

 В поле Motion Type (способ движения камеры ) у вас есть на выбор две опции. 
Если ваша камера стояла жестко на штативе и лишь вращалась в трех измерениях 
( это называется панорамированием), то используется упрощенный способ 
дальнейших расчетов, не учитывающий перемещение самой камеры в 
пространстве. В этом случае выбираем пункт rotation, учитывающий только 
вращение камеры в пространстве. Если же камера работала в более сложных 
условиях, например, с рук, то необходимо выбрать пункт free move,  в этом случае 
программа попытается также просчитать изменение положения самой камеры в 
пространстве ( от переводчика - как предупреждение из личного опыта – делая 
съемки для трекинга, постарайтесь не трогать трансфокатор (зум) без острой 
необходимости. Все трекеры этого очень не любят, так как при этом изменяется 
фокусное расстояние камеры, что приводит к сбоям в расчетах ). 

 Нажмите OK и выбранная последовательность будет загружена. 

File → Load → Initial Camera

Выбор этого пункта меню вызывает открытие окна Первоначальных настроек камеры 
(Initial Camera Parameters) (Рис. 6).

Рис 6. окно Initial Camera Parameter

Вы можете установить параметры камеры вручную, или загрузить их из файла.

 Ручная установка параметров в текстовых полях: 
o Желаемые параметры могут быть занесены в белые текстовые области. 

Только текстовая область с фоном белого цвета может быть 
отредактирована, области с серым фоном – только для чтения. 

o В общем случае нет необходимости заполнять все текстовые области. 
Необходимыми являются лишь два параметра – размерность фильма (Film 
Back) и фокусное расстояние камеры (Focal Length), которые расположены 
на панели General ( главные).  Абсолютные размеры кадра фильма в 
пикселях могут быть любыми. Важно правильно определить соотношение 
длины и высоты кадра, так называемый aspect ratio, устанавливаемый в 
поле  Film Back и соотношение сторон одного пикселя ( Pixel Ratio) . В 
большинстве случаев значение aspect ratios выбирается из двух значений 
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4:3 = 1.33333 или 16:9 = 1.77777. Как определить и где взять эти значения? 
Не волнуйтесь, производители программы позаботились о вас. Щелкните на 
треугольнике справа от панели Type и откроется выпадающее меню со 
всеми наиболее популярными форматами, вам нужно лишь правильно 
выбрать тот формат, в котором был создан ваш файл из списка-подсказки, и 
все параметры сами установятся в требуемые значения. По умолчанию там 
стоит значение Custom – пользовательские настройки.  Если вы не знаете 
фокусного расстояния камеры во время съемки вашей 
видеопоследовательности (Focal Length) это так же поправимо, Voodoo 
Camera Tracker сконфигурирован так, что бы  работать  и со значением по 
умолчанию. Если же вы знаете фокусное расстояние, то введите его в поле 
Focal Length или измените настройки в Main Control Panel, если не 
поменяли здесь – это значительно повысит ваш шанс на качественный 
трекинг в автоматическом режиме с первого прохода. 

o На вкладке Advanced можно установить некоторые дополнительные 
параметры, такие, как главная точка (Principal Point) и радиальные 
искажения (Radial Distortion). Оставьте эти параметры по умолчанию, если 
вы не знакомы с их назначением ( от переводчика - так рекомендует 
инструкция, но от себя добавлю, что при съемках штатным объективом 
камеры на радиальные искажения можно не обращать внимания. Но вот при 
съемке короткофокусными и сверхкороткофокусными насадками («рыбий 
глаз») эти искажения необходимо компенсировать, иначе вы не получите 
сколь-нибудь пригодного трека) . 

o На вкладке Position можно устанавливать текущие параметры для 
выбранного кадра, такие, как координаты и вращение камеры ( если они вам 
известны). Вращение задается, как угол наклона, возвышения и 
панорамирования, представляемые, как углы вращения вокруг трех 
основных осей координат Y-, X- и Z- соответственно. 

o Для каждого кадра видеопоследовательности Voodoo Camera Tracker 
выставляет однозначные параметры камеры в этом кадре. Щелкните на OK 
и все изначальные параметры камеры будут установлены. 

      ●   Загрузка файла CAHV камеры. 

o Voodoo Camera Tracker поддерживает CAHV модель, введенную Yakimovski 
и Cunningham. Параметры этой модели считываются из файлов с 
расширением ".cam". Здесь находиться наибольшая часть информации о 
CAHV camera   модели  . 

o Что бы считать файл камеры CAHV, щелкните на кнопке Load и выберете 
ваш ".cam" файл. 

o Загруженные параметры отразятся на панели. 
o Для каждого кадра видеопоследовательности Voodoo Camera Tracker 

закрепляет один набор параметров камеры, связанный с кадром. 
o Щелкните на OK и все изначальные параметры камеры будут установлены. 

File → Load → CAHV Cameras

Для  каждого  кадра  последовательности  Voodoo Camera Tracker закрепляет  один 
установочный  набор  параметров  камеры,  связанный  с  данным  кадром.  Комплект 
параметров считывается из файлов с расширением ".cam". Для загрузки всех параметров 
камеры  данной  последовательности  выбираем  этот  пункт  меню.  Для  каждого  кадра 
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должен существовать свой файл и файлы должны использовать ту же нумерацию, что и 
последовательность кадров. 

File → Load → Feature Points

За  каждым  кадром  последовательности  the Voodoo Camera Tracker закрепляет  набор 
характерных  точек.  Эти  характерные  точки  могут  записаны  и  считаны  из  файла  с 
расширением ".pnt". Для загрузки всех характерных точек последовательности выбираем 
этот пункт меню. Файлы характерных точек представляют так же последовательность – по 
одному файлу на каждый кадр,  и должны использовать  ту же нумерацию,  что и сами 
кадры. 

File → Load → User Primitives

Этот пункт меню позволяет загрузить пользовательские примитивы, выполненные в STL 
формате  (стереолитография),  которые  затем  могут  быть  размещены  на  изображении  с 
использованием инструментов моделирования из панели  Modelling     Tools  . Voodoo Camera 
Tracker может читать STL файлы в двоичном коде и  в ASCII формате. 

От  переводчика -Voodo  позволяет  сохранять  выходной  файл  трекера  во 
множество форматов, что уже было описано выше. Все команды, для 
этого собраны в меню Save. Но так, как  запись результатов трекинга в 
форматы коммерческих редакторов не имеют отношения к Blender, я их 
опускаю, кому это интересно, обратитесь к оригинальному описанию на  
сайте производителя, а мы переходим сразу к Блендеру.

File → Save → Blender Python Script

При выборе  этого  пункта  меню  Voodoo Camera Tracker экспортирует  предполагаемые 
параметры камеры в пакет 3D анимации, используемого в Блендере скриптового файла на 
языке  Python.  Этот  файл  имеет  (естественно)  расширение  ".py".  Для  работы  с  ним, 
загрузите данный скрипт  в текстовый редактор Блендера  и выполните сценарий (ALT-P). 
Выберите камеру "voodoo_render_cam" и нажмите комбинацию клавиш Ctrl-Numpad 0 
для ее активации. Что бы ваша видеопоследовательность отображалась на фоне в 3D окне 
Блендера,   выполните  следующие  действия  -  [выберите  Windows→Scene→Render 
Buttons→Output] и введите имя файла видеопоследовательности в поле "backbuf".  '#'в 
конце имени файла заменяем на  состоящий из  4  цифр номер фрейма.  Данный способ 
импорта был успешно протестирован на версии Blender 2.42a. 

File → Save → Textfile

Этот  пункт  меню  экспортирует  расчитанные  параметры  камеры  и  3D координаты 
характерных точек в текстовый файл. Вы можете в последствии разобрать этот файл в 
любом редакторе, если желаете написать свой собственный фильтр импорта трека для не 
поддерживаемых к настоящему времени Voodoo Camera Tracker приложений. 

File → Save → CAHV Cameras

Этот  пункт  меню  позволяет  сохранить  файл  камеры  (Saving Camera Files),  при  его 
выборе открывается окно (Рис. 7).
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Рис 7. Окно Saving Camera Files

Для каждого кадра последовательности Voodoo Camera Tracker закрепляет один параметр 
камеры, связанный с этим кадром. Эти параметры могут быть сохранены в файл камеры 
CAHV (расширение ".cam"). Для каждого кадра записывается свой файл.

 Voodoo  Camera  Tracker предлагает  шаблон  файла.  Любой  "#"  в  файле 
автоматически будет замен номером фрейма ( кадра последовательности). 

 Если  вы  хотите  изменить  директорий  для  размещения  файлов,  воспользуйтесь 
кнопкой Browse для выбора нового директория. 

 Voodoo  Camera  Tracker заполняет  номер  стартового  (start)  и  конечного  (end) 
кадров, а так же величину шага,  соответственно в текстовых полях  Start, End  и 
Step величинами, используемыми при трассировке. 

 Щелкните на OK и предпалагаемый параметр камеры будет сохранен. 

File → Save → Feature Points

Для  каждого  кадра  последовательности  Voodoo  Camera  Tracker фиксирует  2D  и  3D 
характерные точки. Эти характерные точки могут быть сохранены в файл с расширением 
".pnt". Для каждого кадра создается один файл.

 Voodoo  Camera  Tracker предлагает  файловый  шаблон.  Любой  "#"  в  файле 
автоматически будет замен номером фрейма ( кадра последовательности). 

 Если  вы  хотите  изменить  директорий  для  размещения  файлов,  воспользуйтесь 
кнопкой Browse для выбора нового директория.  

 Voodoo  Camera  Tracker заполняет  номер  стартового  (start)  и  конечного  (end) 
кадров, а так же величину шага,  соответственно в текстовых полях  Start, End  и 
Step величинами, используемыми при трассировке.

 Щелкните на OK и предпалагаемый набор характерных точек будет сохранен. 

File → Save → User Primitives

Этот  пункт  меню сохраняет  пользовательские  примитивы,  установленные  в  сцене  при 
помощи инструментов моделирования Modelling Tools. 

File → Exit

Выбор этого пункта меню закрывает Voodoo Camera Tracker.

Все не сохраненные данные при этом будут потеряны.
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View → Controls

Выбор этого меню вызывает открытие основной панели управления (Main Control Panel) 
(Рис. 8).

Рис 8. окно Main Control Panel с выбранным детектором Harris.

Вычисление параметров камеры ( трассировка камеры) состоит из пяти основных шагов: 
Обнаружение,  Проведение анализа перемещения характерных точек,  Удаление ошибок, 
Расчет  и  Окончательный  расчет.  Для  каждого  шага   Voodoo  Camera  Tracker может 
использовать различные алгоритмы. Вы свободны в выборе любой другой комбинации 
алгоритмов для каждого шага. Нпример вы можите использовать детекторы угла Harris , 
Foerstner,  или  Susan на шаге  обнаружения.  Некоторые алгоритмы находятся  в стадии 
разработки и, следовательно, неактивны в этой бета-версии Voodoo Camera Tracker. Если 
вы  не  знакомы  с  алгоритмами,  то  оставьте  все  по  умолчанию  или  поиграйтесь  с 
некоторыми параметрами. В случае любой проблемы вы можете свободно обратиться к 
нам за поддержкой.

С Main Control Panel вы можете выбрать любую комбинацию и параметры алгоритмов 
по вашему желанию.

 Щелчек на квадратном боксе перед названием этапа откроет список алгоритмов в 
нем,  а  щелчек  на  круглом  боксе  справа  от  названия  алгоритма  выбирает  этот 
алгоритм. 

 Сигналом к тому, что алгоритм выбран, является появление внутри круглого бокса 
точки, для подтверждения нажмите одну из кнопок - Apply или OK. 

 Если вы щелкните на имени алгоритма, требующего настройки, справа откроется 
панель настроек для данного алгоритма. 

По умолчанию на шаге проведения анализа перемещения характерных точек задействован 
алгоритм KLT Tracking. Он использует свой алгоритм обнаружения характерных точек, 
по этому вы не сможете изменить алгоритм на шаге обнаружения, пока на шаге анализа 
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установлен  метод  KLT  Tracking.  Имеются  два  наиболее  важных  параметра,  которые 
иногда требуется корректировать. Это текстовые поля "Max. Corners" и "Win. Size for 
Local Max.". Поле "Max. Corners" ограничивает колличество характерных точек на один 
фрейм. Если ваша последовательность имеет много контрастных пикселов  и легка  для 
трекинга, вы вполне можете уменьшить количество характерных точек, чем значительно 
ускорите  вычесления.   "Win.  Size  for  Local  Max."  может  быть  использовано  для 
равномерного  распространения  характерных  точек  в  кадрах  последовательности. 
Увеличение  числа  в  этом  поле  увеличивает  распространение  характерных  точек. 
Хорошая равномерность распространения характерных точек  в фрейме очень важна для 
обеспечения  наилучших  результатов  трекинга.  Пожалуйста,  обязательно убедитесь  в 
наличии достаточного количества треков характерных точек как на переднем плане, так и 
на фоне изображения. 

Вы можете так же сами выбрать, или пропустить любой из шагов процесса трассировки, 
установив справа от имени шага флажки  Enable/Skip.  Voodoo Camera Tracker не станет 
выполнять шаг с меткой Skip, а возьмет результаты более раннего выполнения этого шага 
в  памяти,  если  вы  щелкните  на  кнопке  Track.  Эта  возможность  может  быть  очень 
полезной  в  случае,  если вы редактируете,  добавляете  или удаляете  характерные  точки 
вручную (смотрите более подробно в  Modelling Tools ). Если вы не  установите флажок 
Skipна  шаге  проведения  анализа  перемещения  характерных  точек  (Correspondence 
Analysis), все ваши действия по редактированию характерных точек будут потеряны.

View → Draw Options

При  выборе  этого  пункта  меню  откроется  панель  Draw  Options  Deck  (опции 
представления процесса) (Рис. 9). 

Рис 9. Окно Draw Options Deck 
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Настройки параметров  в  этой  панели  влияют на  представление  2D  и  3D  отображения 
результата  и хода трекинга  в  Main  Tracking  Window  (  плоское)  и  в  3D Scene Viewer 
( трехмерное).  Щелкнув на цветной квадрат вы можете выбрать цвет для каждого вида 
представляемой  графической  информации  (  точек,  треков).  Щелкнув  на  крестик  или 
галочку  справа  от  наименования  графического  элемента  вы  можете  включить  или 
отключить  его  отображение  в  окнах  проекции.  Далее  расшифруем  некоторые  важные 
термины и обозначения:

o Inlier:  Характерне  точки  или  линии их  треков,  которые  определены,  как 
надежные,  в  шаге  устранения  ошибок.  Эти  характерные  точки  и  линии 
используются в конечном шаге расчета. 

o Outlier: Характерные точки или линии треков, которые определены как не 
надежные,  на шаге  устранения ошибок.   Этими характерными точками и 
треками пренебрегают на конечном шаге расчетов. 

o FPoints: Ограничение числа характерных точек. 
o FCorrs: Ограничение числа линий  ( характерных) треков. 
o Search  Win:  Окно  поиска  для  создания  линий  треков  между  двумя 

последовательными фреймами на шаге анализа треков точек.
o Polar  Raster:  Используется  для  перевода  отображения  окна  трекинга  в 

полярные  координаты.  Очень  полезен,  когда  точно  известно,  что  камера 
снимала  в  режиме  панорамирования,  то  есть  находилась  на  штативе  и 
изменяла только угол поворота. 

Рис.  10 демонстрирует  пример  результатов  трассировки.  Inlier  выделены  зелеными 
крестиками,  а  outlier,  как  красные  крестики.  Трассы  характерных  точек  нарисованы 
желтым цветом. Одна характерная точка выделена, ее цвет крестика стал синим, а окно, в 
котором  будет  осуществлен  ее  поиск  в  следующем  кадре  –  обведено  оранжевым 
прямоугольником.

Рис.10. Определение характерных точек и их трасс

mult/manual%20voodo.html#3dscene
file:///C:/Users/Max/AppData/manual%20voodoo.htm#maintrack
file:///C:/Users/Max/AppData/manual%20voodoo.htm#figure9


View → Camera Parameter

При выборе этого пункта меню открывается окно параметров камеры Camera Parameter 
(Рис. 11.). 

Рис 11. окно Camera Parameter

Это окно имеет те же текстовые поля,  что и  окно начальной настройки камеры  Initial 
Camera , открываемое из под кнопки Load. Для каждого фрейма видеопоследовательности 
Voodoo  Camera  Tracker закрепляет  один  параметр  камеры,  связываемый с  данным 
фреймом. При замене  отображаемого  фрейма в  окне трекинга   Main  Tracking  Window 
соответственно меняется и параметр  в окне Camera Parameter. Следовательно у вас есть 
доступ к каждому установленному параметру для видеопоследовательности и вы можете 
менять  эти  параметры  в  соответствии  с  вашими  потребностями.  Для  закрепления 
произведенных изменений параметра камеры нажмите кнопку OK или Apply. 

View → 3D Scene Viewer 

Выбор этого пункта из меню открывает окно 3D Scene Viewer (Рис. 12.). 

Рис 12. окно 3D Scene Viewer 
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В этом просмотрщике  3D изображение отображается в глобальной системе 3D координат. 
Единицей  измерения  растровой  системы  координат  является  фокусное  расстояние, 
фактически установленое в настройках камеры. Используя кнопки мыши и удерживая их с 
соответствующими  горячими  клавишами,  можно   осуществлять следующие  действия 
внутри 3D сцены.

клавиша  + 
кнопка мыши перемещение

o + левая Свободное вращение OpenGL камеры вокруг центра 
сцены

o + средняя Вверх/вниз вращение OpenGL камеры вокруг центра 
сцены

o + правая Пямолинейное  движение  вперед/назад  OpenGL 
камеры ( наезд /откат)

u + левая Перемещение   влево/вправо,  вверх/вниз  OpenGL 
камеры 

u + средняя Свободное вращение OpenGL камеры вокруг центра 
сцены

u + правая Инвертированное  пямолинейное  движение  вперед 
назад OpenGL камеры ( наезд /откат)

p + левая Пямолинейное  движение  вперед  назад  OpenGL 
камеры ( наезд /откат)

p + средняя Быстрое  пямолинейное  движение  вперед  назад 
OpenGL камеры ( наезд /откат)

p + правая Очень  быстрое  Пямолинейное  движение  вперед 
назад ( вдоль оси Z) OpenGL камеры ( наезд /откат)

i + левая Перемещение OpenGL камеры вдоль оси x
i + средняя Перемещение OpenGL камеры вдоль оси y
i + правая Перемещение OpenGL камеры вдоль оси z

s Расположение  OpenGL  камеры  в  позиции  CAHV 
камеры

a Сброс позиции OpenGL камеры

d Помещение  OpenGL  камеры  в  выбранную  3D 
характерную точку

f Переворачивает систему координат

Меню  Options окна  3D Scene Viewer содержит вкладку  Draw Options,  где вы можете 
выбрать   -  отображать  в  сцене  3D  объекты,  или  нет,  и  цвета  их  отображения  в  окне 
вьювера.

View → Modelling Tools 



Выбрав этот пункт из меню, вы увидите открывшееся окно Modelling Tools (Рис. 13.). 

Рис 13. окно Modelling Tools 

Панель  инструментов  моделирования  (modelling  tools)  позволяет  быстро  разместить 
простые примитивы в сцене и протестировать с их помощью предполагаемые параметры 
камеры. 

Сначала  создайте  желаемый  примитив,  нажав кнопку с  соответствующим рисунком на 
панели Create. 

Вы можете легко разместить примитив с помощью инструментальной кнопки 2d anchor 
( 2D якорь). Если кнопка 2d anchor нажата, вы можете,  двигая мышью вокруг вершин 
примитива,  выделить  их  (смотрите  Рис.  13).  После  этого  вы  сможете  перемещать 
вершины  на нужные позиции в изображении,  щелкнув на них мышью, и перетащив с 
нажатой  левой кнопкой мыши. Перемещение , вращение и масштабирование примитива 
произойдет автоматически при перемещении вершины. Включая и отключая кнопки  (T)-, 
(R)-, и (S)- при включеной кнопке 2d anchor, вы можете включать/отключать следующие 
изменения параметров примитива (T)ranslation ( перемещение), (R)otation ( поворот), и 
(S)cale  (  масштабирование).  Для  более  точной  установки  вершины  вы  можите 
использовать  кнопку  изменения  масштаба  -  zoom.  Если  вы  хотите  удалить  объект  , 
нажмите клавишу DELETE. 

На  рис. 14  вы можете увидеть результат  установки двух кубов. Вы можете скачать эту 
видеопоследовательность  отсюда и попробовать установить кубы сами. 
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Рис 14. Установлены Кубики 

С помощью кнопки selection (выбор), вы можете выбрать активный примитив. Примитив 
можно выбрать,  щелкнув  на одной из его вершин.  Инструмент selection так же может 
быть  использован  для выбора характерных точек.  Одна  характерная  точка  выбирается 
щелчком левой кнопкой мыши на ней (смотрите FPoint Editor),  если же нужно выбрать 
массив точек, его выбирают перемещением  мыши над характерными точками с нажатой 
правой кнопкой. 

Для  улучшения  оценки  результатов  часто  бывает  очень  полезно  добавить  вручную 
характерные точки трека. Это можно сделать с помощью  нажатия кнопки create feature 
points.  После  этого  щелчек  левой  кнопкой  мыши  создает  новую  характерную  точку 
вблизи  позиции курсора  мыши.  Характерные  точки  выбираются  автоматически.  После 
этого вы можете перейти к следующему кадру и добавить другую характерную точку в 
выбранный трек щелчком правой кнопкой мыши.  Связь между выбранной характерной 
точкой в предыдущем фрейме и соответствующей характерной точкой в следующем кадре 
может быть получена щелчком на последней средней кнопкой мыши. Обратите внимание, 
что  при помощи колеса  прокрутки  мыши можно легко и быстро перемещаться  между 
кадрами в последовательности. Важно, что бы были созданы длительные треки как в на 
фоне  изображения,  так  и  на  переднем  плане,  и  что  бы  они  присутствовали  своими 
характерными  точками  во  всех  фреймах.  Характерные  точки,  добавленные  вручную, 
отмечаются золотым прямоугольником. Они никогда не будут определены, как outliers на 
шаге устранения ошибок ( Outlier Elimination). 

После  того,  как  вы  добавили  характерные  точки  вручную,  вы  можете  попробовать 
произвести  расчет   или  повторный  расчет  параметров  камеры,  нажав  кнопку Track. 
Только прежде убедитесь,  что вы установили галочку Skip step на шагах  Detection  и 
Correspondence Analysis во избежании потери всех ваших изменений характерных точек 
(смотрите Main Control Panel для подробностей).  Иногда это так же имеет смысл делать 
только для того, что бы повторить последний шаг  Final Estimation с новыми , вручную 
установленными, характерными точками.  Тем не менее,  это необходимо делать только, 
если  ваш  результат  расчета  камеры  в  памяти  уже  очень  хорош  и  вам  нужно  только 
добавить  несколько  характерных  точек  для  доведения  его  до  совершенства.  Если  вы 
хотите выполнить только заключительный шаг расчета параметров камеры - Final Estimati, 
не забудьте  установить галочки Skip  на все предыдущие  шаги (смотрите Main Control 
Panel для подробностей). 
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Вы должны сохранить параметры CAHV камеры и характерных точек до того,  как вы 
начнете устанавливать характерные точки вручную. Если вы сохраните эти параметры, то 
всегда сможете загрузить их снова для новой попытки, если что-то вдруг пошло не так. 

Другим вариантом улучшения результатов работы трекера является удаление неудачных 
треков, которые автоматический трекер определил, как удачные. Используйте инструмент 
selection, что бы выбрать характерные точки и удалить их с помощью FPoint Editor. Если 
вы выбрали несколько характерных точек правой кнопкой мыши, вы можете удалить их 
клавишей DELETE. После удаления не верных характерных точек вы можете попробовать 
улучшить  параметры камеры,  нажав на кнопку  Track и  пересчитав  параметры камеры 
(активируйте флажки Skip на шагах Detection и Correspondence Analysis). 

Рис.  15 демонстрирует  последовательность  с  несколькими  добавленными  вручную 
характерными  точками  треков.  Добавленные  вручную  характерные  точки  видно  по 
золотому прямоугольнику вокруг них. Благодаря добавлению характерных точек вручную 
и удалении неверных характерных точек все еще есть шанс получить качественный трек 
камеры  для  такого  низко  качественного  изображения  с  преобладанием  множества 
движущехся объектов, как, например, изображенная на Рис.15:  "Trip Down Market Street 
Before  the  Fire  (1905)",  из  материалов,  являющихся  общественным  достоянием  от 
archive.org

Рис. 15. Добавленные вручную характерные точки.

View → FPoint Track Editor 

Во  время  автоматического  трекинга  характерные  точки  треков  часто  теряются  из-за 
перспективных искажений изображений, используемых для трекинга,  или потому что в 
отслеживаемые треки фона врезаются различные объекты переднего плана, или потому, 
что оттречиваемые характерные точки выходят из поля зрения камеры и вновь входят 
позже. FPoint Track Editor позволяет вновь соединить разорванные треки вручную. Это 
обычно  делается,  когда  вы  получили  достаточно  успешные  параметры  камеры  в 
результате работы трекера и просто хотите их еще более улучшить. 

Выберите FPoint Track Editor при этом откроется окно (Рис. 16). 
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Рис 16. Окно FPoint Track Editor. 
Выберите  характерную  точку  в  первой  части  разорванного  трека,  используя  кнопку 
инструмента selection из Modelling Tools. Затем нажмите левую кнопку From selection на 
панели FPoint Track Editor. Два изображения на левой части FPoint Track Editor теперь 
показывают  соответственно  начало  и  конец  первой  части  разорванного  трека.  Затем 
перейдите к другому фрейму, где начинается вторая часть разорванного трека, и выбирете 
характерную точку начала второй части трека, после чего нажмите правую кнопку From 
selection. Внимательно убедитесь, что все 4 характерные точки появились в виде крестов в 
3D и нажмите кнопку Merge. После того, как вы объединили некоторые из разорванных 
треков, можно попытаться провести повторный запуск последнего шага Final Estimation 
(установите Skip на все шаги, кроме Final Estimation и нажмите кнопку Track). 

Вы  должны  сохранить  параметры  CAHV  камеры  и  характерных  точек  прежде  чем 
пытаться улучшить результаты трекинга вручную. Если объединить не те треки, можно 
получить  не  предсказуемые  результаты.  Если  же  вы  сохранили  полученные  в 
автоматическом режиме параметры CAHV камеры и характерных точек, вы всегда можете 
их вновь загрузить для очередной попытки. 

Если  нажать  кнопку  Automatic  Search в  вкладке  "Automatic  Search  for  Merge 
Candidates" (автоматический поиск кандидатов на слияние), кандидаты на разорванные 
треки ищутся автоматически. Используйте кнопки "Previous" и "Next" для просмотра и 
выбора кандидатов на объединение и нажмите кнопку  Merge ,  когда будете уверены в 
выборе. Имейте в виду что, как правило, нет необходимости объединять всех кандидатов. 
Просто  попытайтесь  объединить  лишь  некоторые  из  них,  например,  50,  после  чего 
проверьте, достаточно ли это улучшит конечный результат. 

FPoint  Track  Editor можно  так  же  использовать  для  удаления  не  желательных 
характерных точек треков. Используйте выпадающий список в панели "Remove FPoint 
Tracks", что бы выбрать то, что вы хотите удалить. Затем нажмите кнопку Remove. 
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Help → Help

Выбор этого пункта меню открывает руководство.

Help → Notify Level

Выбор этого пункта меню открывает окно Notify Level (Рис.. 17). 

Рис. 17. Окно Notify Level 
Выбрав  уровень  уведомления  notify  level вы  можете  изменить  объем  текстовой 
информации на консоли во время работы программы.

FPoint Editor

Рис. 18. Окно FPoint Editor
В окне  FPoint  Editor отображаются параметры характерной точки.  Это окно работает, 
если вы выберите характерную точку нажав кнопку инструмента "selection" из Modelling 
Tools.

mult/manual%20voodo.html#modellingtools
mult/manual%20voodo.html#modellingtools
mult/manual%20voodo.html#figure16


Как достичь отличного результата трекинга.

• Избегайте смаза движения в кадре (motion blur). 
• Избегайте быстрых движений. Расстояние смещения характерных точек от кадра к 

кадру должно быть, желательно, не более 30 пикселей. 
• Избегайте  длительных  последовательностей  —  желательно  не  более  200-400 

кадров. 
• Как правило наиболее надежной для трекинга является последовательность, снятая 

камерой на штативе (Тип движения - вращение). 
• Если  ваша  камера  не  на  штативе  (Тип  движения  —  свободное  перемещение), 

производите  всю запись  с  постоянным фокусным расстоянием (  не  пользуйтесь 
зумом). 

• Снимайте  последовательность  с  как  можно  большим  полем  зрения  (  малым 
фокусным расстоянием). 

• Очень важно генерировать длинные треки как на фоне, так и на переднем плане 
изображения  и  распределять  их равномерно  по всему кадру.  Главной причиной 
неудачи обычно является не достаточное колличество характерных точек треков. 
Если  не  удается  получить  качественный  трекинг,  попробуйте  измененить 
параметры или алгоритмы на шаге Correspondence Analysis  в  Main Control Panel, 
или  добавьте,  отредактируйте,  или  просто  удалите  некоторые  хактерные  точки 
треков вручную с помощью Modelling Tools. 

• Движение камеры расчитывается по отношению к статическому окружению сцены. 
Убедитесь, что движущиеся объекты не занимают большие площади в кадрах. 

• Voodoo Camera Tracker в настоящее время не позволяет создавать и отслеживать 
маски,  закрывающие  области  с  движущимися  объектами,  как  это  делается  в 
коммерческих трекерах. Тем не менее, вы можете вручную удалить характерные 
точки трекаов в некоторых областях изображения с помощью Modelling Tools. 

• Эта  программа  не  является  альтернативой  использованию  тележки  dolly  (за 
исключением  особых  художественных  причин),  потому  что   Voodoo  Camera 
Tracker не может создавать движение камеры по прямой или кривой линии. 

Модель CAHV Камеры
Параметры  CAHV модели камеры: 
(Cx, Cy, Cz)    : CameraPosition [mm]
(Ax, Ay, Az)    : RotationAxis2  [unit vector]
(Hx, Hy, Hz)    : RotationAxis0 [pel] (including FocalLength, PixelSizeX, and 
Principal Point offset) 
(Vx, Vy, Vz)    : RotationAxis1 [pel] (including FocalLength, PixelSizeY, and 
Principal Point offset) 
(K3, K5)        : Radialdistortion  K3 [1/(mm)^2]  K5 [1/(mm)^4]
(sx, sy)        : PixelSize     [mm/pel]
(Width, Height) : ImageSize     [pel]

Внутренние используемые параметры: 
(ppx, ppy)      : Principal Point offset [pel]
f               : Focal Length [mm]
fov              :  Horizontal  Field  of  View  [degree]  = 
(2*atan(0.5*Width*sx/f)*180/PI;
(H0x, H0y, H0z) : RotationAxis0 [unit vector]
(V0x, V0y, V0z) : RotationAxis1 [unit vector]
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2D и 3D координаты: 
(x, y)          : image coordinates [pel]
(X, Y, Z)       : 3D coordinates [mm]

Поекция  3D координат на изображение может быть представлена так: 
 [ x' ] =  [ Hx Hy Hz ] [ 1 0 0 -Cx] [ X ]
 [ y' ] =  [ Vx Vy Vz ] [ 0 1 0 -Cy] [ Y ]
 [ z' ] =  [ Ax Ay Az ] [ 0 0 1 -Cz] [ Z ]
                                     [ 1 ]

или так: 
 [ x' ] =  [f/sx 0    ppx] [ H0x H0y H0z ] [ 1 0 0 -Cx] [ X ]
 [ y' ] =  [0    f/sy ppy] [ V0x V0y V0z ] [ 0 1 0 -Cy] [ Y ]
 [ z' ] =  [0    0    1  ] [ Ax  Ay  Az  ] [ 0 0 1 -Cz] [ Z ]
                                                        [ 1 ]

then x = x'/z' and y = y'/z' , if the origin of the image coordinates is in the center of the 
image,
or  x = x'/z' + 0.5*(Width-1) and  y = y'/z' + 0.5*(Height-1) ,  if  the 
origin of the image coordinates is in the upper left corner. 

Сообщения об ошибках
 Voodoo Camera Tracker разработан в исследовательских целях и , потому, имеет меньше 
возможностей,  чем  подобные  коммерческие  продукты.  Настоятельно  рекомендуем 
рассмотреть покупку коммерческого продукта,  если вы нуждаетесь в трекере камеры с 
профессиональными возможностями. Однако, ваш отчет об опыте работы, важен для нас, 
он  позволит  произвести  необходимое  улучшение  программного  обеспечения  согласно 
вашим потребностям. Пожалуйста, пошлите описания всех ошибок и недостатков Thorsten 
Thormählen  (http://www.tnt.uni-hannover.de/~thormae)  или  Hellward  Broszio 
(http://www.tnt.uni-hannover.de/~broszio). Не смущайтесь входить в контакт с нами в случае 
любой неприятности, связанной с этим программным обеспечением. 
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